<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.okemahnewsleader.com/wp-content/cache/borlabs_cache/1/js/9b4e2f925e4fce5bccf31a56123441e252f7cac6_https.js" as="script">
<link rel="preload" href="https://www.okemahnewsleader.com/wp-content/cache/borlabs_cache/1/css/dd4f678a82898c188f5e4bc5e6119b99b41b6ab5_https.css" as="style">
<link rel="stylesheet" href="https://www.okemahnewsleader.com/wp-content/cache/borlabs_cache/1/css/dd4f678a82898c188f5e4bc5e6119b99b41b6ab5_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="http://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.okemahnewsleader.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.okemahnewsleader.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.okemahnewsleader.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Ronnie Lee Ogden &#8211; Okemah News Leader</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="Okemah News Leader &raquo; Feed" href="https://www.okemahnewsleader.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Okemah News Leader &raquo; Comments Feed" href="https://www.okemahnewsleader.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="Okemah News Leader &raquo; Ronnie Lee Ogden Comments Feed" href="https://www.okemahnewsleader.com/2022/11/18/ronnie-lee-ogden/feed/" /> <meta property="og:title" content="Ronnie Lee Ogden"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.okemahnewsleader.com/2022/11/18/ronnie-lee-ogden/"/><meta property="og:site_name" content="Okemah News Leader"/><meta property="og:image" content="http://media.iadsnetwork.com/facebookthumbnail/facebook.jpg"/>                       <style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.okemahnewsleader.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                        <link rel="https://api.w.org/" href="https://www.okemahnewsleader.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.okemahnewsleader.com/wp-json/wp/v2/posts/249592" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.okemahnewsleader.com/xmlrpc.php?rsd" /> <link rel='prev' title='Donald Lee Rutland' href='https://www.okemahnewsleader.com/2022/11/18/donald-lee-rutland/' /> <link rel='next' title='Oklahoma State Park Bathrooms Receive Upgrades Saving Taxpayers $30M' href='https://www.okemahnewsleader.com/2022/11/18/oklahoma-state-park-bathrooms-receive-upgrades-saving-taxpayers-30m/' /> <link rel="canonical" href="https://www.okemahnewsleader.com/2022/11/18/ronnie-lee-ogden/" /> <link rel='shortlink' href='https://www.okemahnewsleader.com/?p=249592' /> <link rel="alternate" type="application/json+oembed" href="https://www.okemahnewsleader.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.okemahnewsleader.com%2F2022%2F11%2F18%2Fronnie-lee-ogden%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.okemahnewsleader.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.okemahnewsleader.com%2F2022%2F11%2F18%2Fronnie-lee-ogden%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.okemahnewsleader.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>  <style id="wp-custom-css">
			

/*
CSS Migrated from BB theme:
*/

#awesomeweatherwidget-2 {
    background: #fff;
    padding: 10px;
    margin-top: 25px;
    border-radius: 10px;
}		</style> <script src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script><script src='https://www.google.com/recaptcha/api.js?ver=5.5.11' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.okemahnewsleader.com/wp-content/cache/borlabs_cache/1/js/9b4e2f925e4fce5bccf31a56123441e252f7cac6_https.js"></script></head> <body class="post-template-default single single-post postid-249592 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-framework-bootstrap fl-preset-color01 fl-fixed-width fl-has-sidebar" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"><div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-top-bar-menu" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-284 nav-item"><a href="https://www.okemahnewsleader.com/contact-us/" class="nav-link">Contact Us</a></li> <li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-285 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1578.newstogo.us/editionviewer/default.aspx?Publication=2184c1d5-0a54-4669-a4ad-6cd12a073b3c" class="nav-link">E-Edition</a> <ul class="sub-menu"> <li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-287 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1578.newstogo.us/editionviewer/default.aspx?Publication=2184c1d5-0a54-4669-a4ad-6cd12a073b3c&#038;view=archives" class="nav-link">Archives</a></li> </ul> </li> <li id="menu-item-286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-286 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1578.newstogo.us/editionviewer/default.aspx?Publication=2184c1d5-0a54-4669-a4ad-6cd12a073b3c&#038;view=subscribe" class="nav-link">Subscribe</a></li> <li id="menu-item-19566" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19566 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.newsleaderprinting.com/News_Leader_Printing/Pay_your_Bill.html" class="nav-link">Pay Ad Bill</a></li> </ul> <div class="fl-social-icons"> <a href="https://www.facebook.com/okemahnewsleader191/" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span><i aria-hidden="true" class="fab fa-facebook-f mono"></i></a><a href="mailto:Kay@OkemahNewsLeader.com" rel="noopener noreferrer"><span class="sr-only">Email</span><i aria-hidden="true" class="fas fa-envelope mono"></i></a></div> </div> </div> </div> </div> </div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.okemahnewsleader.com" itemprop="url"><img loading="false" data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="http://www.okemahnewsleader.com/wp-content/uploads/2016/08/header-1.png" data-retina="" title="" alt="Okemah News Leader" /><meta itemprop="name" content="Okemah News Leader" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-74859" class="widget widget-webads-weather"> <a id="webads-weather-74859-link" href="https://www.okemahnewsleader.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-74859-temperature" class="temperature"></span> <i id="webads-weather-74859-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-74859-location" class="location"></span> <span id="webads-weather-74859-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form aria-label="Search" method="get" role="search" action="https://www.okemahnewsleader.com/" title="Type and press Enter to search."> <input aria-label="Search" type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" onfocus="if (this.value === 'Search') { this.value = ''; }" onblur="if (this.value === '') this.value='Search';" /> </form> </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076 nav-item"><a href="https://www.okemahnewsleader.com/" class="nav-link">Home</a></li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-296 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1578.newstogo.us/editionviewer/default.aspx?Publication=2184c1d5-0a54-4669-a4ad-6cd12a073b3c" class="nav-link">E-Edition</a></li> <li id="menu-item-19568" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19568 nav-item"><a href="#" class="nav-link">Local News</a> <ul class="sub-menu"> <li id="menu-item-767" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-767 nav-item"><a href="https://www.okemahnewsleader.com/category/area-news/" class="nav-link">Area News</a></li> <li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-766 nav-item"><a href="https://www.okemahnewsleader.com/category/sports/" class="nav-link">Sports</a> <ul class="sub-menu"> <li id="menu-item-19552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19552 nav-item"><a href="https://www.okemahnewsleader.com/category/videos-football/" class="nav-link">Videos &#8211; Football</a></li> </ul> </li> <li id="menu-item-292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-292 nav-item"><a href="https://www.okemahnewsleader.com/obituaries/" class="nav-link">Obituaries</a></li> <li id="menu-item-249096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-249096 nav-item"><a href="https://www.okemahnewsleader.com/category/opinion/" class="nav-link">Opinion</a></li> </ul> </li> <li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1578.newstogo.us/editionviewer/default.aspx?Publication=2184c1d5-0a54-4669-a4ad-6cd12a073b3c&#038;view=subscribe" class="nav-link">Subscribe</a></li> <li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293 nav-item"><a href="https://www.okemahnewsleader.com/photos/" class="nav-link">Photos</a></li> <li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290 nav-item"><a href="https://www.okemahnewsleader.com/event-calendar/" class="nav-link">Events</a></li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289 nav-item"><a href="https://www.okemahnewsleader.com/crossword/" class="nav-link">Crossword</a></li> <li id="menu-item-4243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4243 nav-item"><a href="#" class="nav-link">Regional News</a> <ul class="sub-menu"> <li id="menu-item-4246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4246 nav-item"><a href="https://www.okemahnewsleader.com/oklahoma-news/" class="nav-link">Oklahoma News</a></li> <li id="menu-item-4245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4245 nav-item"><a href="https://www.okemahnewsleader.com/okemah-panthers-news/" class="nav-link">Okemah Panthers News</a></li> <li id="menu-item-4244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4244 nav-item"><a href="https://www.okemahnewsleader.com/oklahoma-city-news/" class="nav-link">Oklahoma City News</a></li> </ul> </li> <li id="menu-item-19569" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19569 nav-item"><a href="#" class="nav-link">Local Links</a> <ul class="sub-menu"> <li id="menu-item-19545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19545 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.okemahok.org/home/pages/index.php" class="nav-link">Chamber of Commerce</a> <ul class="sub-menu"> <li id="menu-item-19551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19551 nav-item"><a href="https://www.okemahnewsleader.com/hall-of-fame-application/" class="nav-link">Hall of Fame Application</a></li> </ul> </li> <li id="menu-item-19565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19565 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.iadsnetwork.com/church/Default.aspx?NetID=me" class="nav-link">Church Directory</a></li> <li id="menu-item-221911" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-221911 nav-item"><a href="https://www.okemahnewsleader.com/city-of-okemah-city-management-form/" class="nav-link">City of Okemah City Management Form</a></li> <li id="menu-item-19550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19550 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.opsfoundation.com/" class="nav-link">Okemah Public School Fondation</a></li> <li id="menu-item-19553" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19553 nav-item"><a href="#" class="nav-link">Public School Info</a> <ul class="sub-menu"> <li id="menu-item-19554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19554 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.bearden.k12.ok.us/" class="nav-link">Bearden Public Schools</a></li> <li id="menu-item-19555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19555 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.graham.k12.ok.us/" class="nav-link">Graham Public Schools</a></li> <li id="menu-item-19556" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19556 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.harrahschools.com/" class="nav-link">Harrah Public Schools</a></li> <li id="menu-item-19557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19557 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.mcloudschools.us/" class="nav-link">McLouds Public Schools</a></li> <li id="menu-item-19558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19558 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.mason.k12.ok.us/" class="nav-link">Mason Public Schools</a></li> <li id="menu-item-19559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19559 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.meeker.k12.ok.us/" class="nav-link">Meeker Public Schools</a></li> <li id="menu-item-19560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19560 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.okemahk12.com/" class="nav-link">Okemah Public Schools</a></li> <li id="menu-item-19561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19561 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.paden.k12.ok.us/" class="nav-link">Paden Public Schools</a></li> <li id="menu-item-19562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19562 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.weleetka.k12.ok.us/" class="nav-link">Weleetka Public Schools</a></li> <li id="menu-item-19563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19563 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.whiterock.k12.ok.us/" class="nav-link">White Rock Public Schools</a></li> </ul> </li> </ul> </li> <li id="menu-item-246255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-246255 nav-item"><a href="https://www.okemahnewsleader.com/classifieds/" class="nav-link">Classifieds</a></li> <li id="menu-item-248742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-248742 nav-item"><a href="https://www.okemahnewsleader.com/letters-to-santa-2021/" class="nav-link">Santa Letters</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.okemahnewsleader.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-249592 post type-post status-publish format-standard hentry category-obituaries" id="fl-post-249592" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Ronnie Lee Ogden </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.okemahnewsleader.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2022-11-18">November 18, 2022</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.okemahnewsleader.com/2022/11/18/ronnie-lee-ogden/#respond" tabindex="-1" aria-hidden="true">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <div class="tabs__panel__header obit-and-service__header"> <h3 class="tabs__panel__title obit-and-service__title">Ronnie Lee Ogden</h3> </div> <div class="tabs__panel__content"> <div class="obit-and-service__obituary"> <div class="obit-and-service__obituary__text"> <div class="obituary edit-container"> <div class="obituary-text edit">Funeral services for Ronnie Lee Ogden will be Monday, November 21, 2022 at 2:00 PM at the Parks Brothers Funeral Home Chapel in Okemah. Interment will follow at the Morse Cemetery of Okemah.</p> <p>Ronnie Lee Ogden was born May 16, 1950 in Okemah, Oklahoma to Ewell Lee Ogden and Louise (Buckhanon) Ogden. He passed away Wednesday, November 16, 2022 at his home in Okemah at the age of 72.</p> <p>Ronnie was a lifelong resident of the Okemah area and a graduate of Weleetka High School. He and Judy Guinn were married May 24, 1969 in Okemah. Ronnie worked many years trimming trees and also as a janitor for Okemah Public Schools for 20 years. He enjoyed deer hunting, fishing, his cattle and more than anything else, spending time with his grandkids.</p> <p>He is preceded in death by his parents; one brother, Ricky and one brother-in-law, Bill Gordon.</p> <p>He is survived by his wife, Judy Ogden of the home; one son, Scott Ogden and wife Barbara of Checotah; one daughter, Melissa Ogden of Okemah; three sisters, Berinda Gordan of Okemah, Glynda Goode and husband Gerald of Okemah and Beverly Wilcox of Henryetta; 6 grandchildren, Kaylin, Courtney, Callie, A.J., Alex and Jessica and one great-grandchild, Liam.</p> <p>Serving as pallbearers will be James Kenneda, Kevin Johnson, Taygen Bryant, A.J. Kenneda, Tory McNabb and John Caleb Guinn.</p> <p>Services will be under the direction of Parks Brothers Funeral Home, Okemah, Oklahoma. Bro. Mark Rich officiating.</p> <p>Online condolences may be made at <a title="Click to open in a new window or tab" href="http://www.parksbrothersfuneralhome.com/" target="_blank" rel="nofollow noopener noreferrer">www.ParksBrothersFuneralHome.com</a>.</div> </div> </div> <p class="obit-and-service__store-obituary-link">To send flowers or a memorial gift to the family of Ronnie Lee Ogden please visit our <a href="https://www.parksbrothersfuneralhome.com/store/Category.aspx?CategoryId=319&amp;icn=desktop_memorial_obituary_link#chooser">Sympathy Store</a>.</p> </div> <div class="obituary__section"></div> </div> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.okemahnewsleader.com/2022/11/18/ronnie-lee-ogden/" data-a2a-title="Ronnie Lee Ogden"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.okemahnewsleader.com%2F2022%2F11%2F18%2Fronnie-lee-ogden%2F&amp;linkname=Ronnie%20Lee%20Ogden" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.okemahnewsleader.com%2F2022%2F11%2F18%2Fronnie-lee-ogden%2F&amp;linkname=Ronnie%20Lee%20Ogden" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.okemahnewsleader.com/category/obituaries/" rel="category tag">Obituaries</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.okemahnewsleader.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='249592' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <input type="hidden" id="ct_checkjs_65658fde58ab3c2b6e5132a39fae7cb9" name="ct_checkjs" value="0" /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2022/11/18/ronnie-lee-ogden/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.okemahnewsleader.com/2022/11/18/donald-lee-rutland/" rel="bookmark" title="Donald Lee Rutland">Donald Lee Rutland</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 18, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.okemahnewsleader.com/2022/11/18/donald-lee-rutland/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.okemahnewsleader.com/2022/11/18/rev-harry-james-anderson/" rel="bookmark" title="Rev. Harry James Anderson">Rev. Harry James Anderson</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 18, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.okemahnewsleader.com/2022/11/18/rev-harry-james-anderson/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.okemahnewsleader.com/2022/11/18/dennis-richard-rose/" rel="bookmark" title="Dennis Richard Rose">Dennis Richard Rose</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 18, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.okemahnewsleader.com/2022/11/18/dennis-richard-rose/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.okemahnewsleader.com/2022/11/08/edwin-dale-landers/" rel="bookmark" title="Edwin Dale Landers">Edwin Dale Landers</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 8, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.okemahnewsleader.com/2022/11/08/edwin-dale-landers/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.okemahnewsleader.com/2022/11/05/betha-m-hodges/" rel="bookmark" title="Betha M. Hodges">Betha M. Hodges</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 5, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.okemahnewsleader.com/2022/11/05/betha-m-hodges/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-24 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Auction Spotlight', 1.00, {'nonInteraction': 1});" href="https://www.purplewave.com/auction/221130?utm_source=pw&utm_medium=third_party&utm_campaign=web_ad&utm_term=auction&utm_content=221130ve" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Auction Spotlight', 2.00, {'nonInteraction': 1});" src="https://www.okemahnewsleader.com/wp-content/uploads/2022/11/purple.jpg" /></a></div><div class="g-dyn a-3 c-2"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Employment', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1081" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Employment', 2.00, {'nonInteraction': 1});" src="http://www.okemahnewsleader.com/wp-content/uploads/2016/08/Jobs.png" /></a></div><div class="g-dyn a-23 c-3"><a onClick="ga('send', 'event', 'Adverts', 'click', 'United For Oklahoma - Side', 1.00, {'nonInteraction': 1});" href="https://ad.doubleclick.net/ddm/trackclk/N3535.3268749OKPRESSASSOCIATION/B28672366.348756409;dc_trk_aid=540054528;dc_" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'United For Oklahoma - Side', 2.00, {'nonInteraction': 1});" src="https://www.okemahnewsleader.com/wp-content/uploads/2022/10/united-for-ok.jpg" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="http://www.okemahnewsleader.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="http://www.okemahnewsleader.com/wp-content/uploads/2016/04/breakingNewsHeader.png" /></a></div></aside><aside id="webads_facebook_widget-2" class="fl-widget widget_webads_facebook_widget"><h4 class="fl-widget-title">Like Us On Facebook</h4> <div id="fb-root"></div>  <div class="fb-page" data-href="https://www.facebook.com/okemahnewsleader191/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div> </aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  </aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-1"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Okemah News Leader</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="http://www.okemahnewsleader.com/">Home</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.okemahnewsleader.com/contact-us/">Contact Us</a></li> <li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a target="_blank" rel="noopener noreferrer" href="http://1578.newstogo.us/editionviewer/default.aspx?Publication=2184c1d5-0a54-4669-a4ad-6cd12a073b3c">E-Edition</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" rel="noopener noreferrer" href="http://1578.newstogo.us/editionviewer/default.aspx?Publication=2184c1d5-0a54-4669-a4ad-6cd12a073b3c&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-232"><a target="_blank" rel="noopener noreferrer" href="http://1578.newstogo.us/editionviewer/default.aspx?Publication=2184c1d5-0a54-4669-a4ad-6cd12a073b3c&#038;view=archives">Archives</a></li> <li id="menu-item-19567" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19567"><a target="_blank" rel="noopener noreferrer" href="http://www.newsleaderprinting.com/News_Leader_Printing/Pay_your_Bill.html">Pay Ad Bill</a></li> </ul></div></aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-2"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> <div><ul class="menu"> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.okemahnewsleader.com/syndicated_category/united-states/">US</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.okemahnewsleader.com/syndicated_category/sports/">Sports</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.okemahnewsleader.com/syndicated_category/entertainment/">Entertainment</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.okemahnewsleader.com/syndicated_category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.okemahnewsleader.com/syndicated_category/political/">Politics</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.okemahnewsleader.com/syndicated_category/world/">World</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.okemahnewsleader.com/syndicated_category/business/">Business</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.okemahnewsleader.com/syndicated_category/health/">Health</a></li> </ul></div> </aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-3"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.okemahnewsleader.com/crossword/">Crossword Puzzle</a></li> <li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.okemahnewsleader.com/event-calendar/">Event Calendar</a></li> <li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218"><a href="https://www.okemahnewsleader.com/photos/">Photo Galleries</a></li> <li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.okemahnewsleader.com/poll/">Online Poll</a></li> </ul></div></aside></div> </div> </div> </div> <div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>               
</body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 2.78324294 sec
Time to load cache: 0.27514505
Cache file created on: 2022-11-18T22:12:20+00:00
Current time: 2022-11-18T22:12:38+00:00
-->